写在开头

在当今的时代,高墙逐渐变厚,大陆人想连接世界变得越来越困难。但是,得益于我们渴望Link的心,我们身处大陆的人也能链接世界。

一、Shadowsocks标准客户端

Shadowsocks项目:Github
相关文档已被删除。但是还是被大部分人保存了下来。Shadowsocks官方linux客户端并没有GUI界面,需要手动编译配置。

Debian/Ubuntu

apt-get install python-pip
pip install shadowsocks

Arch Linux

sudo pacman -S yaourt
yaourt shadowsocks-git

CentOS

sudo yum install python-setuptools
easy_install pip
pip install --upgrade pip
sudo pip install shadowsocks

二、ShadowsocksR标准客户端

ShadowsocksR项目:Github
ShadowsocksR官方linux客户端集成了ss的优良传统,也没有GUI界面,仍需手动配置。

安装

git clone https://github.com/ssrbackup/shadowsocksr

以下为GUI界面版ss及ssr客户端。

三、Shadowsocks-Qt5

Github项目:点击
这是基于Qt的GUI版Shadowsocks客户端。

  • Shadowsocks-Qt5是用Qt 5用C ++编写的。
  • 支持流量统计
  • 支持服务器延迟(滞后)测试
  • 同时使用多个配置文件

CentOS 7

wget https://copr.fedorainfracloud.org/coprs/librehat/shadowsocks/repo/epel-7/librehat-shadowsocks-epel-7.repo
sudo mv librehat-shadowsocks-epel-7.repo /etc/yum.repos.d/
sudo yum update
sudo yum install -y shadowsocks-qt5

Ubuntu

sudo add-apt-repository ppa:hzwhuang/ss-qt5
sudo apt-get update
sudo apt-get install shadowsocks-qt5

Debian

  • 安装主要依赖
sudo apt-get install python-m2crypto
sudo apt-get install qt5-qmake qtbase5-dev libqrencode-dev libappindicator-dev libzbar-dev libbotan1.10-dev
  • 安装libQtShadowsocks
git clone https://github.com/shadowsocks/libQtShadowsocks.git
cd libQtShadowsocks
sudo dpkg-buildpackage -uc -us -b
cd ..
sudo dpkg -i libqtshadowsocks_1.8.0-1_amd64.deb
sudo dpkg -i libqtshadowsocks-dev_1.8.0-1_amd64.deb
  • 安装shadowsocks-qt5
cd shadowsocks-qt5
sudo dpkg-buildpackage -uc -us -b
cd ..
sudo dpkg -i shadowsocks-qt5_2.6.0-1_amd64.deb

Arch Linux

sudo pacman -S yaourt
yaourt shadowsocks-qt5

四、electron-ssr

electron-ssr是一个非常美观的GUI界面SSR客户端,支持订阅等若干高级功能。
另外,Appimage文件支持几乎所有Linux发行版,不用考虑依赖问题。

注:Github项目已删除,请从Hayai-SSR官网下载备份版本。
Github项目:点击

Last modification:November 23rd, 2019 at 12:43 am
赞助一杯冰阔落